summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2023-02-26 21:09:02 +0100
committerSimon Streit <simon@netpanic.org>2023-06-19 21:36:36 +0200
commit0deb077860b20cf447c3f258d265fb5cf20b744c (patch)
tree267fe5d3efaad2be64edbf9df21343f8279060ca
parent553d1c9792bbf4ccf31d4215fcd773cccc3c8ca3 (diff)
siguix: Remove volctl
* siguix/packages/volctl.scm: Remove file.
-rw-r--r--siguix/packages/volctl.scm63
1 files changed, 0 insertions, 63 deletions
diff --git a/siguix/packages/volctl.scm b/siguix/packages/volctl.scm
deleted file mode 100644
index 36bb891..0000000
--- a/siguix/packages/volctl.scm
+++ /dev/null
@@ -1,63 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
-;;;
-;;; This file is NOT part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (siguix packages volctl)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gnome)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages pulseaudio)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages xorg)
- #:use-module (guix build-system python)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix hg-download)
- #:use-module (guix packages)
- #:use-module (siguix packages python-pulsectl)
- #:use-module (siguix packages statusnotifier))
-
-(define-public volctl
- (package
- (name "volctl")
- (version "0.9.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/buzz/volctl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vxikmvf3qlv571c71qqb7b3nm3ks2hg7qdwjpxh305b1app8nca"))))
- (build-system python-build-system)
- (inputs (list gtk+ libxfixes pulseaudio python-pulsectl
- statusnotifier))
- (propagated-inputs (list python-click python-pycairo python-pygobject
- python-pyyaml))
- (home-page "https://buzz.github.io/volctl/")
- (synopsis
- "Per-application volume control and on-screen display (OSD) for graphical desktops")
- (description
- "Volctl is a PulseAudio-enabled tray icon volume control and OSD
-applet for graphical desktops. It's not meant to be an replacement
-for a full-featured mixer application. If you're looking for that
-check out the excellent pavucontrol.")
- ;; XXX: 'setup.py' says "GPLv2" but nothing says "version 2 only". Is
- ;; GPLv2+ intended?
- (license license:gpl2)))