summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2022-03-02 08:59:43 +0100
committerSimon Streit <simon@netpanic.org>2022-03-02 08:59:43 +0100
commitb8f2de802622b3df81d874ac66bc002edfccfa1e (patch)
tree0b10a05aa44c38df8264473b612820186fd69c24
parent2ffba9a1f56af9e849316c8477e5a3e3aae3ba24 (diff)
siguix: volctl: Update to 0.9.2.
* siguix/packages/volctl.scm (volctl): Update to 0.9.2.
-rw-r--r--siguix/packages/volctl.scm35
1 files changed, 15 insertions, 20 deletions
diff --git a/siguix/packages/volctl.scm b/siguix/packages/volctl.scm
index d5d2e55..8af724e 100644
--- a/siguix/packages/volctl.scm
+++ b/siguix/packages/volctl.scm
@@ -34,33 +34,28 @@
(define-public volctl
(package
(name "volctl")
- (version "0.9.1")
+ (version "0.9.2")
(source (origin
(method git-fetch)
- (uri (git-reference (url "https://github.com/buzz/volctl")
- (commit (string-append "v" version))))
+ (uri (git-reference
+ (url "https://github.com/buzz/volctl")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1pp70fnjszzin812iis9hgwfr769xlqfp6f50xrg3nb0r2vs5ch3"))))
+ "0vxikmvf3qlv571c71qqb7b3nm3ks2hg7qdwjpxh305b1app8nca"))))
(build-system python-build-system)
- (inputs
- `(("gtk+" ,gtk+)
- ("libxfixes" ,libxfixes)
- ("pulseaudio" ,pulseaudio)
- ("python-pulsectl" ,python-pulsectl)))
- (propagated-inputs
- `(("python-click" ,python-click)
- ("python-pycairo" ,python-pycairo)
- ("python-pygobject" ,python-pygobject)
- ("python-pyyaml" ,python-pyyaml)))
+ (inputs (list gtk+ libxfixes pulseaudio python-pulsectl))
+ (propagated-inputs (list python-click python-pycairo python-pygobject
+ python-pyyaml))
(home-page "https://buzz.github.io/volctl/")
- (synopsis "Per-application volume control and on-screen display (OSD) for graphical desktops")
- (description "Volctl is a PulseAudio-enabled tray icon volume control and
-OSD applet for graphical desktops. It's not meant to be an replacement for a
-full-featured mixer application. If you're looking for that check out the
-excellent pavucontrol.")
-
+ (synopsis
+ "Per-application volume control and on-screen display (OSD) for graphical desktops")
+ (description
+ "Volctl is a PulseAudio-enabled tray icon volume control and OSD
+applet for graphical desktops. It's not meant to be an replacement
+for a full-featured mixer application. If you're looking for that
+check out the excellent pavucontrol.")
;; XXX: 'setup.py' says "GPLv2" but nothing says "version 2 only". Is
;; GPLv2+ intended?
(license license:gpl2)))