summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--siguix/packages/gnucash.scm134
-rw-r--r--siguix/packages/mpd.scm4
2 files changed, 136 insertions, 2 deletions
diff --git a/siguix/packages/gnucash.scm b/siguix/packages/gnucash.scm
new file mode 100644
index 0000000..2763c9d
--- /dev/null
+++ b/siguix/packages/gnucash.scm
@@ -0,0 +1,134 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
+;;; Copyright © 2020 Christopher Lam <christopher.lck@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Simon Streit <simon@netpanic.org>
+;;;
+;;; This file is NOT part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (siguix packages gnucash)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gnucash)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public gnucash-mod
+ (package/inherit gnucash
+ (name "gnucash-mod")
+ (arguments
+ (substitute-keyword-arguments (package-arguments gnucash)
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-online-test
+ (lambda _
+ (call-with-output-file "libgnucash/app-utils/test/CMakeLists.txt"
+ (lambda (port)
+ (display "set(CTEST_CUSTOM_TESTS_IGNORE online_wiggle test-lots)" port)))))
+ (add-after 'unpack 'set-env-vars
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; At least one test is time-related and requires this
+ ;; environment variable.
+ (setenv "TZDIR" (search-input-directory inputs "share/zoneinfo"))
+ (substitute* "CMakeLists.txt"
+ (("set\\(SHELL /bin/bash\\)")
+ (string-append "set(SHELL " (which "bash") ")")))))
+ (add-after 'set-env-vars 'set-toolbar-style
+ ;; (lambda _ ;Just icons
+ ;; (substitute* "gnucash/gnome-utils/gnc-embedded-window.c"
+ ;; (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_ICONS"))
+ ;; (substitute* "gnucash/gnome-utils/gnc-main-window.cpp"
+ ;; (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_ICONS"))
+ ;; (substitute* "gnucash/gnome/window-reconcile.c"
+ ;; (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_ICONS")))
+ (lambda _ ;both horizontal
+ (substitute* "gnucash/gnome-utils/gnc-embedded-window.c"
+ (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_BOTH_HORIZ"))
+ (substitute* "gnucash/gnome-utils/gnc-main-window.cpp"
+ (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_BOTH_HORIZ"))
+ (substitute* "gnucash/gnome/window-reconcile.c"
+ (("GTK_TOOLBAR_BOTH") "GTK_TOOLBAR_BOTH_HORIZ"))))
+ ;; The qof test requires the en_US, en_GB, and fr_FR locales.
+ (add-before 'check 'install-locales
+ (lambda _
+ (setenv "LOCPATH" (getcwd))
+ (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
+ (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
+ (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")))
+ ;; There is about 100 MiB of documentation.
+ (add-after 'install 'install-docs
+ (lambda _
+ (mkdir-p (string-append #$output:doc "/share"))
+ (symlink (string-append
+ #$(this-package-native-input "gnucash-docs")
+ "/share/help")
+ (string-append #$output:doc "/share/help"))))
+ (add-after 'install 'split-python-bindings
+ (lambda _
+ (let ((python-bindings (string-append
+ "lib/python"
+ #$(version-major+minor
+ (package-version python)))))
+ (mkdir-p (string-append #$output:python "/" python-bindings))
+ (copy-recursively
+ (string-append #$output "/" python-bindings)
+ (string-append #$output:python "/" python-bindings))
+ (delete-file-recursively
+ (string-append #$output "/" python-bindings)))))
+ (add-after 'install-docs 'wrap-programs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (for-each
+ (lambda (prog)
+ (wrap-program (search-input-file
+ outputs (string-append "bin/" prog))
+ `("GNC_DBD_DIR" =
+ (,(search-input-directory inputs "lib/dbd")))
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (o)
+ (string-append o "/lib/perl5/site_perl/"
+ #$(package-version perl)))
+ (if (string=? prog "gnc-fq-helper")
+ (list
+ #$@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote"
+ "perl-date-manip"))))
+ (list
+ #$@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote")))))))))
+ '("gnucash"
+ "gnc-fq-update"))))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))))))))
diff --git a/siguix/packages/mpd.scm b/siguix/packages/mpd.scm
index 081f3ad..ff54f23 100644
--- a/siguix/packages/mpd.scm
+++ b/siguix/packages/mpd.scm
@@ -74,7 +74,7 @@
(define-public mympd-mod
(package/inherit mympd
(name "mympd-mod")
- (version "14.0.4")
+ (version "14.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -83,4 +83,4 @@
(file-name (git-file-name name version))
(sha256
(base32
- "105hq5hnhkrfxgsrpkmvv59y6aiv1z4qnpjq38m1lkx3m6xpgy4h"))))))
+ "1fhcnypcf9c34imj2yx41ni4jv4brgxwfw8bl8c8fcxp11cpkl68"))))))